Skip to main content
Version: 4.38.x.x RR

Requirements

To develop authentication plugins, the following software must be available in your development environment:

  • Linux (recommended)
  • JDK 1.8 (must)
  • nevisAuth SDK (must)
  • Maven 3 (must, to be able to use the provided project archetypes)

Furthermore, we recommend using an integrated development environment such as Eclipse or IntelliJ. To be able to test your authentication plugin, have access to a NEVIS integration environment which must consist of at least nevisProxy, nevisAuth and nevisLogrend.